Package org.forgerock.opendj.ldap.requests
Classes and interfaces for core LDAP requests.
-
Interface Summary Interface Description AbandonRequest The Abandon operation allows a client to request that the server abandon an uncompleted operation.AddRequest The Add operation allows a client to request the addition of an entry into the Directory.AnonymousSASLBindRequest The anonymous SASL bind request as defined in RFC 4505.BindClient An authentication client which can be used to bind to a server.BindRequest The Bind operation allows authentication information to be exchanged between the client and server.CancelExtendedRequest The cancel extended request as defined in RFC 3909.CompareRequest The Compare operation allows a client to compare an assertion value with the values of a particular attribute in a particular entry in the Directory.CRAMMD5SASLBindRequest The CRAM-MD5 SASL bind request as defined in draft-ietf-sasl-crammd5.DeleteRequest The Delete operation allows a client to request the removal of an entry from the Directory.DigestMD5SASLBindRequest The DIGEST-MD5 SASL bind request as defined in RFC 2831.ExtendedRequest<S extends ExtendedResult> The Extended operation allows additional operations to be defined for services not already available in the protocol; for example, to implement an operation which installs transport layer security (seeStartTLSExtendedRequest).ExtendedRequestDecoder<R extends ExtendedRequest<S>,S extends ExtendedResult> A factory interface for decoding a generic extended request as an extended request of specific type.ExternalSASLBindRequest The External SASL bind request as defined in RFC 4422.GenericBindRequest A generic Bind request which should be used for unsupported authentication methods.GenericExtendedRequest A generic Extended request which should be used for unsupported extended operations.GSSAPISASLBindRequest The GSSAPI SASL bind request as defined in RFC 2831.ModifyDNRequest The Modify DN operation allows a client to change the Relative Distinguished Name (RDN) of an entry in the Directory and/or to move a subtree of entries to a new location in the Directory.ModifyRequest The Modify operation allows a client to request that a modification of an entry be performed on its behalf by a server.PasswordModifyExtendedRequest The password modify extended request as defined in RFC 3062.PlainSASLBindRequest The Plain SASL bind request as defined in RFC 4616.Request The base class of all Requests provides methods for querying and manipulating the set of Controls included with a Request.SASLBindRequest The SASL authentication method of the Bind operation allows clients to authenticate using one of the SASL authentication methods defined in RFC 4513.SearchRequest The Search operation is used to request a server to return, subject to access controls and other restrictions, a set of entries matching a complex search criterion.SimpleBindRequest The simple authentication method of the Bind Operation provides three authentication mechanisms: An anonymous authentication mechanism, in which both the name and password are zero length.StartTLSExtendedRequest The start TLS extended request as defined in RFC 4511.UnbindRequest The Unbind operation allows a client to terminate an LDAP session.WhoAmIExtendedRequest The who am I extended request as defined in RFC 4532. -
Class Summary Class Description AbstractExtendedRequest<R extends ExtendedRequest<S>,S extends ExtendedResult> An abstract Extended request which can be used as the basis for implementing new Extended operations.Requests This class contains various methods for creating and manipulating requests.