Package org.forgerock.openam.radius.common
This package in large part contains classes for generating java class representation of RADIUS attribute messages
and vice versa.
-
Interface Summary Interface Description Authenticator Abstract superclass of all authenticator types.RadiusCommonConstants Define some module wide constants. -
Class Summary Class Description AccessAccept Represents in java object for the Access-Accept packet specified in section 4.2 of RFC 2865.AccessChallenge Represents in java object for the Access-Challenge packet specified in section 4.4 of RFC 2865.AccessReject Represents in java object for the Access-Reject packet specified in section 4.3 of RFC 2865.AccessRequest Represents in java object for the Access-Request packet specified in section 4.1 of RFC 2865.Attribute Legacy class from before enum types were supported and holder of constants of all defined radius attribute type codes outlined in RFC 2865.AttributeFactory Translates the attribute type code held in the first octet of the on-the-wire representation of a specific radius attribute into the corresponding java object used to interact with attribute fields of that type.AttributeSet Holder of the attribute instances in an instance of thecom.sun.identity.authentication.modules.radius.client.Packettype which is the superclass of all radius packet types.MessageAuthenticatorAttribute Represents the Message-Authenticator attribute (type 80) defined in section 3.2 of RFC 3579 (originally introduced by RFC 2869).OctetUtils This class centralizes much of the conversion code that is repeated throughout many attributes that have the same model implementations.Packet Represents a RADIUS packet and all contained attribute fields.PacketFactory Provides unmarshalling from the on-the-wire radius byte stream to the corresponding java objects.ReplyMessageAttribute Class representing the structure of the Reply-Message attribute as specified in section 5.18 of RFC 2865 and able to be instantiated from the on-the-wire bytes.RequestAuthenticator The Request Authenticator implementation as outlined in section 3 of RFC 2865.ResponseAuthenticator Represents the response authenticator as defined in section 3 of RFC 2865.StateAttribute Class representing the structure of the State attribute as specified in section 5.24 of RFC 2865 and able to be instantiated from the on-the-wire bytes.UserNameAttribute Class representing the structure of the User-Name attribute as specified in section 5.1 of RFC 2865 and able to be instantiated from the on-the-wire bytes or model objects.UserPasswordAttribute Class representing the User Password Attribute as defined in section 5.2 of RFC 2865.Utils Debugging tool for serializing into space separated hex values for each byte of a sequence of octets or for reading such a formatted string into a sequence of octets. -
Enum Summary Enum Description AttributeType Attribute types corresponding to attribute type codes defined in rfc 2865 and extension RFCs.PacketType The packet types in RADIUS rfc 2865 and 2866.